Cisco CME

Content

About

Version 9

Version 4

Used Symbols

About

Simplify the transition from legacy telephony to unified communications and collaboration at the branch office. Cisco Unified Communications Manager Express is a customizable solution that is affordable, simple to deploy, and scalable. Provide localized call control, mobility, and conferencing alongside data applications on Cisco Integrated Services Routers.

  • Converged voice, video, and data with full-featured call processing for enterprise branch deployments of 450 or fewer users
  • Support for Cisco IP voice and video endpoints
  • Deployed on Cisco Integrated Services Routers
  • Includes features especially designed for retail and branch deployments

Tip

  • Due to a known bug, 2N Intercom IP is not able to register to Cisco 4331, IOS version 16.7.1. The recommended solution is to upgrade Cisco 4331 to IOS version 16.7.2 or downgrade to IOS version 16.6.4.

Version 9

Tested with

Cisco CME 2N IP Intercom
Registration
Calls
9.0 2.4.0.8.8 (green star) (green star)

Settings

  2N IP Intercom Settings

2N IP Intercom Configuration

2N IP intercom is connected as an extension of CME 9.0.

2N IP intercom will be added with the following parameters:

- user Intercom_IP

- station 9003

- MAC address 7C1EB30012F1

- IP address 192.168.21.180

Video Codecs Settings:

  Cisco CME Complete Configuration:

CME 9.0 Configuration

prglab-tunnel-gw#sh ver

Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.2(2)T, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2011 by Cisco Systems, Inc.

Compiled Tue 15-Nov-11 22:10 by prod_rel_team

ROM: System Bootstrap, Version 15.0(1r)M9, RELEASE SOFTWARE (fc1)

prglab-tunnel-gw uptime is 1 hour, 42 minutes

System returned to ROM by reload at 15:01:31 CET Mon Dec 12 2011

System restarted at 15:03:13 CET Mon Dec 12 2011

System image file is "flash:c2900-universalk9-mz.SPA.152-2.T.bin"

Last reload type: Normal Reload

Last reload reason: Reload Command

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

Cisco CISCO2911/K9 (revision 1.0) with 487424K/36864K bytes of memory.

Processor board ID FCZ1513213X

3 Gigabit Ethernet interfaces

1 terminal line

DRAM configuration is 64 bits wide with parity enabled.

255K bytes of non-volatile configuration memory.

254464K bytes of ATA System CompactFlash 0 (Read/Write)

License Info:

License UDI:

-------------------------------------------------

Device#      PID              SN

-------------------------------------------------

*0     CISCO2911/K9          FCZ1513213X     

Technology Package License Information for Module:'c2900'

-----------------------------------------------------------------

Technology    Technology-package           Technology-package

             Current       Type           Next reboot  

------------------------------------------------------------------

ipbase        ipbasek9      Permanent      ipbasek9

security      None          None           None

uc            uck9          EvalRightToUse uck9

data          None          None           None

Configuration register is 0x2102

prglab-tunnel-gw#wr t

Building configuration...

Current configuration : 4228 bytes

!

! Last configuration change at 16:39:53 CET Mon Dec 12 2011

! NVRAM config last updated at 16:39:05 CET Mon Dec 12 2011

! NVRAM config last updated at 16:39:05 CET Mon Dec 12 2011

version 15.2

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

no service password-encryption

!

hostname prglab-tunnel-gw

!

boot-start-marker

boot system flash c2900-universalk9-mz.SPA.152-2.T.bin

boot-end-marker

!

!

enable password c

!

no aaa new-model

clock timezone CET 1 0

clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 2:00

!

no ipv6 cef

!

!

!

!

!

no ip domain lookup

ip cef

multilink bundle-name authenticated

!

!

!

!

!

crypto pki token default removal timeout 0

!

!

voice-card 0

!

!

!

voice service voip

allow-connections sip to sip

sip

 bind control source-interface GigabitEthernet0/1.92

 bind media source-interface GigabitEthernet0/1.92

 registrar server expires max 3600 min 120

 transport switch udp tcp

!

voice class codec 1

codec preference 1 g722-64

codec preference 2 g711alaw

codec preference 3 g711ulaw

codec preference 4 ilbc

codec preference 5 g729r8

video codec h263+

video codec h264

!

!

voice register global

mode cme

source-address 10.111.4.1 port 5060

max-dn 10

max-pool 10

authenticate register

authenticate realm 10.111.4.1

dialplan-pattern 1 911. extension-length 4

tftp-path flash:

create profile sync 0001263635328702

camera

video

!

voice register dn  1

number 9111

!

voice register dn  2

number 9003

!

voice register pool  1

id mac 1C17.D341.903D

type 9971

number 1 dn 1

dtmf-relay rtp-nte

voice-class codec 1

username cisco password cisco

camera

video

!

voice register pool  2

id mac 7C1E.B300.12F1

type P600

number 1 dn 2

dtmf-relay rtp-nte

voice-class codec 1

username Intercom_IP password 1234

camera

video

!

!

!

!

!

license udi pid CISCO2911/K9 sn FCZ1513213X

license accept end user agreement

license boot module c2900 technology-package uck9

!

!

!

redundancy

!

!

!

!

!

!

interface Tunnel102

description WARLAB - Warsaw LAB (mostrows@cisco.com,konolsze@cisco.com,szreter@cisco.com)

ip address 10.111.102.2 255.255.255.252

keepalive 10 3

tunnel source 10.62.8.33

tunnel destination 10.62.1.2

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

ip address 10.62.8.33 255.255.255.192

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/1.92

description TVSS LAB - PRAGUE

encapsulation dot1Q 92

ip address 10.111.4.1 255.255.255.0

ip helper-address 10.10.111.100

!

interface GigabitEthernet0/1.93

encapsulation dot1Q 93

ip address 10.111.5.1 255.255.255.0

!

interface GigabitEthernet0/1.94

encapsulation dot1Q 94

ip address 10.111.6.1 255.255.255.0

!

interface GigabitEthernet0/1.95

encapsulation dot1Q 95

ip address 10.111.7.1 255.255.255.0

!

interface GigabitEthernet0/2

no ip address

shutdown

duplex auto

speed auto

!

router ospf 1

redistribute static

passive-interface default

no passive-interface GigabitEthernet0/1.92

network 10.111.4.0 0.0.0.255 area 0

network 10.111.20.0 0.0.0.255 area 0

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 10.62.8.1

ip route 10.10.111.0 255.255.255.0 Tunnel102

!

!

!

!

control-plane

!

!

!

!

!

!

!

mgcp profile default

!

!

!

sip-ua

!

!

!

gatekeeper

shutdown

!

!

telephony-service

max-ephones 10

max-dn 10

ip source-address 10.111.4.1 port 2000

max-conferences 8 gain -6

transfer-system full-consult

create cnf-files version-stamp 7960 Dec 12 2011 15:15:51

!

!

ephone-dn  1  dual-line

number 9101

!

!

ephone-dn  2  dual-line

number 9102

!

!

ephone  1

mac-address 5475.D02B.2BD5

type 6941

button  1:1

!

!

!

alias exec c conf t

alias exec s show run

!

line con 0

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

password c

login

transport input all

!

scheduler allocate 20000 1000

ntp logging

ntp source GigabitEthernet0/0

ntp update-calendar

ntp server 171.68.10.150

ntp server 171.68.10.80

!

end

prglab-tunnel-gw#

Version 4

Tested with

Cisco CME
2N IP Intercom
Registration
Calls
4.1 2.4.0.8.8 (green star) (green star)

Settings

  How to configure it with 2N IP Intercom?

In order to configure CCME, please download Cisco Configuration Professional 2.3 from ip address below:

Download

2N IP intercom will be added as station number 3336, IP address 192.168.22.26

Settings example from another installation site:

voice register dn  54

number 620

call-forward b2bua busy 888

pick-up-group 3

name Intercomunicator

no-reg

label Intercomunicator

voice register pool  54

busy-trigger-per-button 1

id mac 7C1E.B300.8097

type ATA

number 1 dn 54

cor incoming DDN default

cor outgoing INTERNAL default

dtmf-relay rtp-nte

voice-class codec 1

username 620 password cisco

no vad

Used Symbols

(tick) - Verified with video

(green star) - Verified with audio only

(warning) - Work with limitation

(error) - Incompatible